The store not working?

Hey all,

I tried accessing the store earlier today and I got this message:

This page isn’t working is currently unable to handle this request.HTTP ERROR 500

Any ideas why?


  • An_SDP40F_fanAn_SDP40F_fan Member Posts: 11

    There is two versions. The other one is I guess a 404 error for me...

  • Echo117AEcho117A Member Posts: 4

    I'm getting error 500. When I clear cookies and refresh I'm able to access the store again but whenever I do anything I get the error again.

  • PerRockPerRock Administrator Posts: 69

    There is a bug with the software I use, I've raised it with the developer & they're looking into it. You must click on the product title & not the image to get to the product page.

    As it's not my software, fixing it is not in my control.

  • Echo117AEcho117A Member Posts: 4

    I attempted using edge instead of chrome because I can't access the store at all on chrome and when I attempted using your method I was only able to open up the following items: Metrolink Bombardier BiLevel, SunRail BBL Pack, Amtrak Heritage Dining Cars, Go Transit Bombardier Bilevels - New Paint, Metra BBL Pack, Tri-Rail BBL Pack, ATSF El Capitan Hi-Levels, Amtrak 40th Anniversary #145, and Go Transit CanCar BiLevels. When I attempted to add the previously mentioned items to cart I started getting error 500 after the second one and when I attempted to access the cart I got the same error.

  • Echo117AEcho117A Member Posts: 4

    I tried it on my iphone using safari and I was able to access everything I mentioned in my last post and I was also able to add more then 2 items to cart.

Sign In or Register to comment.